Delayed Toast Orders
Incident Report for QSR Enterprise
Resolved
This incident has been resolved.
Posted May 14, 2024 - 10:47 EDT
Monitoring
As of 2:24 PM EDT, QSR is no longer detecting unsuccessful API calls for retrieving orders due to Rate limiting. We have received communication from Toast that the interruption was due to continuing troubleshooting efforts. QSR will continue to monitor for unsuccessful API calls that may impact your operations. If there is any deterioration in Toast's API service in the future, we will provide updates as soon as they are available from their Development Teams.
Posted May 09, 2024 - 14:54 EDT
Identified
QSR's monitoring tools are currently detecting unsuccessful API calls for retrieving orders due to rate limiting imposed by Toast. This issue may be causing delays in order display within your ConnectSmart Kitchen system. We are communicating with Toast to troubleshoot this issue and will share updates as they become available.
Posted May 09, 2024 - 14:20 EDT
Update
Toast has notified QSR that they have lifted the rate limiting applied to our account this weekend as of 4:52 EDT on Sunday, May 5, 2024. This restriction was initially enforced due to issues Toast encountered with the load their API services were experiencing. We are currently monitoring QSR services, and there are no indications of failed or blocked responses at this time. If there is any deterioration in Toast's API service in the future, we will provide updates as soon as they are available from their Development Teams.
Posted May 06, 2024 - 13:41 EDT
Monitoring
QSR is continuing to work with Toast to identify the root cause of the incident. To provide immediate relief to our mutual customers, Toast has taken action to release the intermittent blocking that caused order delays in ConnectSmart Kitchen.

Our Development team has confirmed successful requests for orders from Toast to ConnectSmart Kitchen as of 10:00AM ET. There may still be intermittent issues with very short delays until a root cause is identified and resolved. However, your sites should not see the delay times for order display they experienced yesterday and earlier today. We will remain vigilant and will provide further updates as we continue to monitor the situation closely. Should your site experience any further long delays or other issues, please contact us immediately so we may investigate.
Posted May 05, 2024 - 10:51 EDT
Investigating
Our engineers are actively investigating an issue affecting orders from Toast POS to ConnectSmart Kitchen. Customers may experience delays up to several minutes for order delivery to ConnectSmart Kitchen.

We appreciate your patience as we work to resolve this issue promptly. Stay tuned for further updates.
Posted May 04, 2024 - 16:28 EDT
This incident affected: Toast Connect.