Kitchen Enterprise Reporting
Incident Report for QSR Enterprise
Resolved
This incident has been resolved.
Posted Nov 17, 2022 - 20:03 EST
Investigating
We are currently experiencing increased failure rates with our Kitchen Enterprise reporting. Our Engineers are aware of and are investigating the incident.
Posted Nov 17, 2022 - 18:41 EST
This incident affected: ConnectSmart Platform (Portal Reports).