Issues with Inbound Support Calls
Incident Report for QSR Enterprise
Resolved
Issues with inbound calls have now been resolved.
Posted Apr 22, 2024 - 13:09 EDT
Investigating
We are currently experiencing issues with inbound calls to our Support Desk. Users have reported that while calls are connecting, those involved in the conversation are unable to hear each other.

Thank you for your patience and understanding as we work to have this issue resolved.
Posted Apr 22, 2024 - 11:04 EDT
This incident affected: Support Channels (Support Phone System).