Our phone provider has completed their emergency maintenance and our phone system has been restored. Thank you for your patience and understanding while the system was down.
Posted Jan 27, 2025 - 16:06 EST
Update
Our phone provider has notified us that they will need to perform emergency maintenance on the phone service. The maintenance downtime is expected to last approximately 15 minutes as they work to fully stabilize their systems. If you need to reach out to QSR for a support issue, please create a ticket by emailing Support@QSRAutomations.com.
Posted Jan 27, 2025 - 15:12 EST
Monitoring
QSR has been made aware of an issue affecting our inbound Support lines. Our provider is working towards a resolution. If you try to call into QSR support and are not able to get through, please open a support ticket by emailing Support@QSRAutomations.com
Posted Jan 27, 2025 - 13:38 EST
This incident affected: Support Channels (Support Phone System).