Toast Order Delays
Incident Report for QSR Enterprise
Resolved
This incident has been resolved.
Posted Nov 30, 2024 - 21:34 EST
Identified
Toast System Status is reporting degraded performance for Order Processing / KDS and Online Ordering. This incident is affecting QSR services causing delayed and or missing orders. We are monitoring the issue and will update when their systems are fully operational and QSR order processing issues are resolved. You may check the Toast Status at https://status.toasttab.com/
Posted Nov 30, 2024 - 20:07 EST
This incident affected: Toast Connect.