A fix has been pushed by our service provider to address the issue affecting our Support phone lines.
We are now in a monitoring to confirm full stability and ensure all calls are connecting reliably.
We appreciate your patience and will provide a final update once we confirm the issue is fully resolved. If you continue to experience reaching support by phone, please email Support@QSRAutomations.com for immediate assistance.
Posted Nov 25, 2025 - 11:20 EST
Investigating
We are currently experiencing an issue with our Support phone lines. Some customers may be unable to connect when calling QSR Support.
Our team is actively engaged with our service provider to resolve this issue as quickly as possible.
Alternative Support: If you are unable to reach us by phone, please create a support ticket by emailing us at Support@QSRAutomations.com.
We apologize for any inconvenience this may cause and will provide an update as soon as more information is available.
Posted Nov 25, 2025 - 09:33 EST
This incident affected: Support Channels (Support Phone System).