QSR Support Phoneline

Incident Report for Crunchtime Kitchen and Host

Resolved

This incident has been resolved.
Posted Jul 14, 2025 - 17:34 EDT

Identified

Our phone provider has implemented a fix and is beginning to see recovery across their systems.

If you're unable to reach QSR Support by phone, please email us at Support@QSRAutomations.com to open a support ticket. We’ll continue to monitor the situation and provide updates as needed.
Posted Jul 14, 2025 - 14:09 EDT

Investigating

QSR has been made aware of an issue affecting our inbound Support lines. Our provider is working towards a resolution. If you try to call into QSR support and are not able to get through, please open a support ticket by emailing Support@QSRAutomations.com
Posted Jul 14, 2025 - 12:41 EDT
This incident affected: Support Channels (Support Phone System).