Issues with QSR Support phone system

Incident Report for QSR Enterprise

Resolved

This incident has been resolved.
Posted Jul 28, 2021 - 12:31 EDT

Monitoring

The phone issues appear to be resolved, but we are continuing to monitor for further issues.
Posted Jul 27, 2021 - 17:25 EDT

Investigating

We are experiencing issues with the stability and call quality of incoming support calls. Our phone systems vendor is aware of the issue and is working to resolve.

If you have a support issue you may reach our support department via email (support@qsrautomations.com).
Posted Jul 27, 2021 - 11:03 EDT
This incident affected: Support Channels (Support Phone System).