Toast Integration Issue - Order Delays

Incident Report for Crunchtime Kitchen and Host

Resolved

This incident has been resolved.
Posted Jul 16, 2026 - 09:28 EDT

Monitoring

Mitigation efforts have been successful, and we are seeing recovery in kitchen orders reaching displays within acceptable thresholds. We will continue monitoring the situation closely to ensure services remain stable.
Posted Jul 15, 2026 - 19:48 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 15, 2026 - 19:18 EDT

Update

We have identified a possible cause for the Toast integration issue and have begun taking mitigation steps. We will continue to monitor the impact on kitchen orders and provide further updates as progress is made.
Posted Jul 15, 2026 - 19:17 EDT

Investigating

We are currently investigating an issue with our Toast integration. During this time, customers may experience delays in orders reaching Kitchen displays. We are actively working to resolve this and will provide updates as they become available.
Posted Jul 15, 2026 - 19:06 EDT
This incident affected: Toast Connect.