Software Download Disruptions via ControlCenter

Incident Report for Crunchtime Kitchen and Host

Resolved

This incident has been resolved.
Posted Jul 13, 2026 - 15:29 EDT

Investigating

We are currently investigating an issue preventing customers from downloading software packages from the ControlCenter platform.

Our third-party secure file storage provider is experiencing technical difficulties, which is directly impacting download functionality. Our team is actively monitoring their status and working to mitigate the impact. We will provide another update as soon as more information becomes available.
Posted Jul 10, 2026 - 12:30 EDT
This incident affected: Crunchtime Platform (ControlCenter).