Status Update: Support Unavailability Due to Microsoft Outage

Incident Report for QSR Enterprise

Resolved

This incident has been resolved.
Posted Mar 01, 2025 - 16:52 EST

Identified

We are currently experiencing a major outage affecting our support phone lines and email services due to an ongoing issue with Microsoft. As a result, our support team is temporarily unavailable.
We understand this may cause inconvenience, and we appreciate your patience as we work with Microsoft to resolve the issue as quickly as possible. We will provide updates as soon as more information becomes available.
Posted Mar 01, 2025 - 16:33 EST
This incident affected: Support Channels (Support Phone System, Support Email).