Critical System Alert: ConnectSmart Kitchen/Controlpoint Communication Issues

Incident Report for Crunchtime Kitchen and Host

Resolved

This incident has been resolved.
Posted Oct 16, 2025 - 18:25 EDT

Monitoring

We're happy to share a successful resolution for customers experiencing issues with Printing and the ConnectSmart Host clients unable to connect to the server.

The fix involves installing a specific Microsoft update:
Action: Install the Security Intelligence Update for Microsoft Defender Antivirus - KB2267602 from Microsoft.
Result: Customers have reported that installing this update successfully resolves the issues with both Printing and ConnectSmart Host functionality.

After installing the update, please restart your server if you don't observe the immediate effect of the resolution.

We appreciate your patience as we worked to resolve this. If issues persist after taking these steps, please contact our support team.
Posted Oct 16, 2025 - 12:24 EDT

Update

We are continuing to investigate the root cause related to the Windows updates. A secondary impact has been discovered: connectivity between ConnectSmart Host clients and the ConnectSmart Server is also affected.
Posted Oct 15, 2025 - 18:42 EDT

Investigating

We are currently experiencing a critical issue affecting communication between ConnectSmart Kitchen (CSK) and ControlPoint, resulting in failed print jobs.

Details:
The issue is triggered by the deployment of recent Microsoft Updates on Windows 11 servers. Our analysis confirms that the following specific Knowledge Base updates are disrupting the necessary network protocols:

KB5066835
KB5066131

Immediate Resolution (Action Required):
At this time, the only way to immediately restore reliable printing functionality is for customers to uninstall (rollback) the two problematic Microsoft updates from the affected Windows 11 servers running ConnectSmart Kitchen and ControlPoint. If you require assistance with the rollback process, please contact our Support team.

Long-Term Investigation:
We understand that rolling back security updates is not an ideal long-term solution. To address this, we have escalated the issue to our Development team. Their priority is to:
1. Determine the precise root cause of the incompatibility.
2. Evaluate if a code change to our ConnectSmart Kitchen or ControlPoint application can rectify the issue, allowing customers to safely apply the Microsoft updates in the future.

**Support Volume Advisory**
Due to the critical nature of this issue and the necessary rollback action, we are currently experiencing an extremely high volume of Support calls.
1. Hold times may be longer than normal.
2. If your issue is not urgent, we recommend submitting a ticket via email to Support@Qsrautomations.com to avoid lengthy hold times.

We appreciate your patience as our teams work tirelessly to manage the high call volume and develop a permanent fix.

Next Update:
We will provide a status update regarding the progress of the Development team's investigation into the long-term fix as information is available
Posted Oct 15, 2025 - 15:25 EDT
This incident affected: Crunchtime Platform (Server Connectivity).